WordPress Plugin Compatibility Checker

Right before the upcoming WordPress 2.8 you also should check out if all your Plugins are compatible with Version 2.8 before you upgrade. There is a great website which includes over 5000 Plugins, where you can see if the Plugin will work with WordPress 2.8.

Also very interesting for all Plugin developer, you can see in detail, why your Plugin is not working with the newest version or what can be done better. Really informational! Check it out!

The only thing what would make this even better, if all the Plugins would have a number and this list would have an additional column, where you see the number of a Plugin, which is not compatible with the according Plugin. But I guess, that would be too much work.

But I have to say, respect to the guys of BraveNewCode, that they keep this list up to date! Chapeau!





16 responses to “WordPress Plugin Compatibility Checker”

  1. JamieO Avatar

    That is a great tool. My Idealien Category Enhancements plugin is only missing one test – $wbdp->prepare statement – which I will update in my next release that will support 2.8 and child themes.

    Other thoughts:
    -Create a Bookmarklet that triggers the validation process from a plugin that is hosted the plugin gallery.
    -Version specific tests matching WP releases enabling this to become a core element of unit testing for plugins.

  2. John Hawkins Avatar

    I can’t tell you the amount of times I’ve thought of getting some people together to help build something exactly like this!

    It was also pretty cool to go there and see that the plugin I wrote a while back passed the test and is ready for 2.8!


  3. […] WordPress Plugin Compatibility Checker […]

  4. WpDite Avatar

    WoW! really a great tool for making me prepared for the stable release of WordPress 2.8.

  5. Alex Avatar

    Looks like this one was in need. Glad it helps users and Plugin developers of WordPress aswell.

    @JamieO, good suggestions!

  6. […] in handy whenever you want to make a decision to upgrade to a newer version of WordPress. Thanks Alex (No Ratings Yet)  Loading …   Tags: Compatibility Checker, Plugin Compatibility, […]

  7. Kirk M Avatar

    I just checked out the plugin compatibility chart mentioned in the post you referenced and I found it to be inaccurate to the extreme when bouncing 3 popular plugins against the list (which was supposedly updated June 2, 2009). Here’s what the list says about:

    WP Super Cache: Not compatible (WP max version=2.5)

    All in One SEO Not compatible (WP max version=2.5)

    Aksimet Not compatible (WP max version=2.5)

    All 3 above plugins are fully compatible up to WP 2.7.1 (Max version not listed in WP plugins directory but it’s always compatible).

    No digs meant here and thanks for the info but I wouldn’t use this list to check plugin compatibility for 2.8. Not when it red marks 3 of the most popular and regularly updated plugins for WordPress.

  8. Duane Storey Avatar

    Hey guys, I wrote most of the plugin checker, so I thought I would chime in. Having written probably ten plugins now, I’ve learned the hard way how not to do certain things. I tried to incorporate that data into the plugin checker in such a way that the results can be generated automatically.

    Unfortunately with any such system there are going to be false positives. My goal here was to provide a resource to plugin developers to check their code and hopefully make a few corrections that will lead to a wider audience. I’ve solicited feedback from many individuals, including a few people at Automattic — it’s obviously not perfect, but I’ll continue doing iterations on it based on feedback from real world users.

    I’ve had a lot of positive feedback from people who found bugs immediately and fixed them. I’ve also received some negative feedback from people who think this is a dig at their ability to code, which it isn’t. In fact, I found several bugs in my own code using this tool. One of the prime failures is that people have wp-content hardcoded in their plugins. So yes, it will technically work on a base installation of WordPress 2.5 where the user hasn’t moved their wp-content directory. But since it won’t work on WordPress 2.5 installations where the user has moved their wp-content directory, I consider that the plugin is not fully compatible with that version.

    But I’m glad many people enjoy this tool. It’s just a passive effort, and we’ll continue it as long as we can improve it and help everyone create better plugins. Thanks for the blog entry.

    Duane Storey

  9. Milan Petrovic Avatar

    Great tool, and a lot of potential, but the results are not correct in most of the cases. It analyzes code to see used functions. I have several plugins on the list, and here is a for instance:

    GD Star Rating plugin requires minimum of WP 2.5, and works with latest WP 2.8 inlcuding new widget model. But plugin checker says that it works with 1.5 and up to 2.5. The reason for this is use of wp-content, and the reason I used it is to make plugin compatible with 2.5, for 2.6 and higher different things are used. This plugin is tested and it can work with nothing less than 2.5.

    The similar is with all the other plugins, and my guess is that more than 50% of results here are false, and I noticed a lot of similar problems with many plugins I looked in the list (nextgen gallery, akismet, all in one seo and more are all compatible with WP2.8, yet in the list they are WP2.5). So, this data is more missleading than useful.

    I would like to see this developed further, but for now this will be very confusing to follow. This checker must use compatibility data included by the plugin authors with each plugin, because so far that was very accurate.

  10. Duane Storey Avatar

    Hi Milan,

    I actually have some logic to determine whether or not the code is doing different things for wp-content based on future versions of 2.5. In your case, you’re probably doing something else that the algorithm is not looking for. I’ll scan through your code and try to add some logic to detect it.

    I think it defeats the purpose to simply look at the plugin compatibility area in the plugin repository and assume that it does actually support that. Pretty much every developer I know simply updates the text on that whenever there is a new version without doing any type of real testing (other than simply installing it and testing it in the default scenario). The point of the tool is to try and detect problems that the developer of the plugin may not have been aware of or may not have accounted for.

    Thanks for the feedback though — I’ll try to integrate some changes in the next release and reduce the # of false positives for wp-content.

  11. Milan Petrovic Avatar

    Hello Duane,

    It would be nice to see improved algorithm, because I like the idea. I was expecting something similar on WP Extend. But…

    Scanning for functions and determining the use of the functions is very, very tricky to implement because there are over 5000 plugins on WP Extend, and there are so many different techinques used, and so many ways to use a function that I am very sceptical that it can be done at all.

    Problem is not only max WP version, but a minimal also. Only one of my plugins work with WP 2.0, all the others require at least 2.5, and none of them works with any WP lower than 2.0. And I test my plugins with range of WP versions. According to your list most plugins works with WP1.5, and in 90% of cases that is not true.

    I would like to see two more columns in the table, that will show min and max versions author added to the read me file. That will help to get the full picture. But, at this point this list is not usable.

  12. Milan Petrovic Avatar

    And one more thing. 99% of all widget plugins available right now don’t work with WP2.8 beacuse of major change in the widget and sidebar code. To see a WP2.8 compatibility for these plugins you need to search for WP_Widget class use, and I think that this is not done yet. Also, one plugin can be compatible with both widget systems. My GD STar Rating plugin have dual code for widgets, and it detects WP versions, and uses widgets for that version.

  13. Alex Avatar

    Great to see this discussion going on and I’m sure it will help Duane to improve the checker. Of course it is very difficult to have a perfectly correct checker and everybody should see it more as a reference to see if the Plugins in their blog are working in the newest version. Also for Plugin developer it is a nice resource to look at.

    Maybe more Plugin Developer (thanks Milan) can provide Duane some helpful advices to improve the checker.

  14. codestyling Avatar

    This checker tool is very interesting and also impressive. But also the huge amount of “false positive” detections disappoint me in the same moment. As example it checks, if any PHP 5 only function occures and states this in red for the whole plugin forced by failed PHP 4 test.

    In my case i have used the function “scandir” (only PHP 5) but additionally tested of existance and re-introduced for PHP 4:

    if (!function_exists(‘scandir’)) {
    function scandir(…) …

    The checker doesn’t detect a conditional re-introduce of missing functions, so i’m afraid, a lot of other plugins may fail doing it also safe this way!

  15. NFL Rumors Avatar

    Nice web site. I always wondered if there was a web site that could check if plugins would be compatible with the newest WordPress. The bad part, you find out that your plugins are not all compatible. Which sucks.

  16. Okoth Avatar

    Page doesn’t exist anymore. Please update post!